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Working with Sophie2. 

Sophie’s 2.1. interface
There are three main parts of the Sophie interface: the workspace, the left flap, and 
the right flap. The workspace is the gray area in the center of the Sophie window. It’s 
the background, but it does things: dragging things onto the workspace will make a 
new Sophie book.

Flaps are the things that stick out on the left and right side of the Sophie window; 
you can adjust the size of the flaps by dragging the orange margin back and forth. 
Each flap has several tabs in it, which can be selected by clicking the tab name. Most 
tabs contain more than one palette. Palettes can be lists of things used in Sophie (like 
all the movies in a book) or tools (like the spellchecker). There’s also a bottom flap, 
which you’ll see when you open a timeline, but this flap doesn’t appear automatically.

Sophie has menu bars, but they’re not used for very much. Most of the things you 
can do in Sophie can be done through the flaps or halos and HUDs.

2.2. Halos and HUDs
Interacting with Sophie is done with halos and HUDs. Halos are little icons that show 
up around things in Sophie when you select them. They stay on the screen until you 
click somewhere else in Sophie. Generally, these halos can be clicked to open a HUD; a 
few work slightly differently. HUD is short for head-up display. It’s a little window that 
opens up showing you different things that you can do with whatever you have selected.

Here’s an example. If you click on a blank page in Sophie, a little gray square will 
appear. This is the page halo. If you click it, the page HUD will open. It contains set-
tings that let you control the background color of the page.

Different things in Sophie have different kids of halos. If you select an image on 
a Sophie page, you’ll see a frame halo, which lets you put images, backgrounds, or 
drop shadows on the image; a content halo, which lets you control where and how 
big the image is; a link halo, which lets you turn the image into a link; and an anchor 
halo, which lets you attach the image to a text flow. If you select a word of text, you’ll 
see the character halo, which lets you set the font settings for just that word; the para-
graph halo, which lets you control how the paragraph that word is in appears; and the 
link halo, which lets you make that word into a link. Some halos are very specific: you 
won’t see the link color halo unless you’ve selected a frame that’s a link or text that’s 
part of a link.

This is a HUD.

These are halos.

Workspace

Left flap

Right flap



4

Generally the most used settings in a HUD are near the top of the window. Some-
times you’ll see a downward facing arrow at the bottom of a HUD. These arrows can 
be clicked to unfold more functionality in the HUD (and clicked again to hide the 
functionality). Some HUDs have several of these arrows.

One special kind of halo is the little clock which appears in the upper right hand 
corner of a frame, image, or movie that is selected on a Sophie page. Clicking on this 
halo doesn’t open a HUD; however, this halo can be dragged to a timeline if you want 
the object to appear on a timeline. (You don’t want to drag the object itself because 
you probably want it to stay in the same place on the page.) The anchor halo can simi-
larly be dragged to the place in a text flow where you want to anchor a frame.

Besides halos, Sophie frames have a few basic controls that appear when the frame 
is selected. The orange edges that appear can be dragged up and down or back and 
forth to change the frame’s size and shape. Corners can also be dragged to change 
the shape of the frame. There’s a little orange circle that appears in the center of the 
frame; this can be dragged to move the frame around the page. (This is especially 
important in text frames: if you click other places inside the text frame, Sophie will 
assume that you want to put your cursor in text.) And finally, there’s a little green 
square in the upper right corner of the frame. If you drag this, you can rotate the 
frame.

To learn about specific halos and HUDs, choose one from the list:

Object halos:
Frame halo • Content halo • Link halo • Link color halo • Anchor halo • Time-based 
media halo • Align halo

Text halos:
Character halo • Paragraph halo • Link halo • Link color halo

Page halos:
Page halo

2.2.1. Frame halo
The frame halo controls how the frame appears. The frame halo allows you to set the 
background of a frame (which can be a color, a gradient of colors, an image, or noth-
ing). Setting the background has no effect on a movie and most images, although 
images with transparency can take on different backgrounds. The default background 
for all frames is solid white. In addition to setting the background for a frame, the 
frame halo can also be used to set a border on a frame and to add a drop shadow be-
hind the frame. 

Rotate handle

Clock halo

Drag handle

Edges Dragging a frame

Rotating a frame

Dragging a corner

Dragging an edge

Color picker

Frame HUD
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Some of the settings in the frame halo use the color picker square. If you click on 
this square, a color picker will appear, allowing you to set the color for the selected 
functionality.

2.2.2. Content halo
The content halo allows you to specify where on the page a frame appears (with x and 
y coordinates) as well as the width and height of the frame. You can also use the con-
tent halo to change the z-order of a frame (whether it appears below or above other 
frames) and to determine whether text should wrap around a frame (by default, text 
wraps around frames). 

If you unfold the content HUD, there are settings for margins and padding. Mar-
gins are used when you have text inside a frame: they determine how much space 
should come between the frame and the text. Padding is extra space around a frame: 
if you have an image that appears in a column of text, you might add some padding 
to put a margin around it.

2.2.3. Link halo
The link halo is used to create links. Links in Sophie have three parts: something that 
triggers the link (the reader clicking a frame or text, for example, or the page open-
ing), an action that is performed (a timeline is played, a frame is shown, the book 
jumps to the next page), and finally what’s used to perform that action (the timeline 
to play, the frame to show, the page number to jump to). 

The link HUD includes three windows that are used to represent these three parts 
of the link. The top drop-down menu lists possible triggers. The middle drop-down 
menu lists possible actions to take. And the third drop-down menu changes depend-
ing on what kind of link is selected. If the action is to open a URL, you can type in 
the URL in the third box. If the action is to open a timeline, you can drag the timeline 
from the timeline palette to the third box. If the action is to show or hide a frame, 
drag the little flag near the box to the frame you want to show or hide.

The “+” and “–” at the bottom of the link HUD allow you to make more complex 
links: the same frame or text can be part of several different links.

Link color halo2.2.4. 
When you’ve created a link, the link color halo appears. When your link is text, the 
link color HUD shows four color boxes: one for the link when it hasn’t been clicked, 
one for when the reader’s mouse is over the link, one for when the reader is clicking 
the link, and the final one for the color the link is after it’s been clicked. If you click 
any of the color squares, a color picker will appear allowing you to change the color 
for the link.

The link color halo is slightly different if you’ve made a link out of a frame. In this 
case, the link color halo appears a lot like the frame halo: you can set different back-

Content HUD (expanded)

Link HUD

Link color HUD (for a frame)

Link color HUD (for text)
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ground and border settings for when the link hasn’t been clicked, when the reader 
mouses over the link, when the reader clicks the link, and when the reader has al-
ready clicked the link. The drop boxes at the bottom of this HUD allow you to drop in 
other images to fill the frame: this lets you make buttons.

Anchor halo2.2.5. 
The anchor halo is used to anchor frames to a particular point in a text flow. You 
might do this if you have an image that should appear beside a certain paragraph of 
your text; that paragraph happens to be on page 5 right now, but if more text is added 
below it, it might end up being on page 20. While you could just drop the image on 
page 5 next to the text, if the text changes the image will be on the wrong page; if the 
image is anchored, it will move with the text to which it is attached. 

To anchor a frame in a text flow, drag the anchor halo from the frame you want to 
anchor to the point in a flow frame to which you want to anchor it. A line is drawn 
between the two frames. The anchor HUD then appears. The main thing displayed 
in the anchor HUD is the anchor style, in the drop-down menu; this controls the way 
in which the anchored frame is moved relative to the flow in which it is anchored. 

“Page”, the default style, means that the anchored frame will always appear on the 
same page as the point in the flow to which it is anchored. If the anchor point is at 
the bottom of page 2, the anchored frame will appear on page 2; if the anchor point is 
pushed over to page 3, the anchored frame will appear on page 3 in the same position. 

Other anchor styles are possible. If the style is “inline”, the frame will be moved 
into the text of the flow at the anchor point. You might do this if you want to include 
a small graphic in your text (an elaborate star, for example). “Character” positions the 
anchor relative to the position of the anchor point in the line. If you anchor an image 
with this style to a position at the start of the line, then add words before the anchor 
point, the image will move to the right. If you add lines above the anchor point in 
the flow frame, the anchored image will move down. “Line” does the same thing, but 
doesn’t move the anchored frame relative to the anchor point’s position in the line. 

“Paragraph” moves the anchored object relative to the paragraph of the anchor point; 
“Frame” moves the anchored object relative to the frame that the anchor point is in.

For “Page”, “Paragraph”, and “Frame”, you can choose a control point: this selects 
which corner (or the center) of the page, paragraph, or frame the anchored object is 
moved relative to. Note that in Sophie RC7, this isn’t working properly.

Frames can only be anchored in a flow frame or a non-flow frame, though they 
don’t do very much when anchored in a non-flow frame. Once a frame has been an-
chored, you can always open the anchor HUD to change anchor settings. 

2.2.6. Time-based media halo
The time-based media halo only appears on audio and video that has been dragged 
to the page. This is a simple HUD: it includes checkboxes that ask if you want the 

Time-based media HUD

Anchor HUD
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media to play when shown and whether a controller should be shown. If “play when 
shown” is checked, the media will start playing as soon as the page of the book that it 
appears on is opened. (What this checkbox does, actually, is to create a link: open the 
link HUD to see what it does.) If “show controller” is checked, play and pause but-
tons are shown that the reader can use.

2.2.7. Align halo
The align halo only appears when more than one frame is selected. You can select 
multiple frames by clicking the first frame, then holding down command or control 
and clicking more frames. If you click the align halo, you’ll be presented with op-
tions for ways to arrange the frames. It’s an easy way to automatically line up a lot of 
frames quickly.

2.2.8. Character halo
The character halo is used when you want to change how text looks: you can change 
the font, style, size, and color of the text you’re using. Part of the paragraph HUD 
looks exactly like the character HUD. The ones in the paragraph HUD are character 
settings for the entire paragraph: if you want your entire paragraph to be 36-point 
red Helvetica, you should change it in the paragraph HUD. If you only want a single 
word to be 36-point red Helvetica, you should select that word and change it in the 
character HUD.

2.2.9. Paragraph halo
The paragraph halo is used when you want to change how an entire paragraph looks. 
You can change linespacing; whether the paragraph is left-, center-, or right-aligned; 
the indentation of the paragraph; and whether space should be added before or after 
the paragraph. If you unfold this HUD all the way, you’ll see character settings. These 
are character settings for the whole paragraph: if you want your entire paragraph to 
be 36-point red Helvetica, you should change it here. If you only want a single word 
to be 36-point red Helvetica, you should change it in the character HUD.

Paragraph styles can be saved for reuse. If you want all of your headers to be 36-
point centered Helvetica with 18 points of space after them, you can click the little 
disc at the top of this HUD to save the style. You’ll be prompted for a name for your 
style; once you save it, it will appear in the list of paragraph styles in the styles tab. To 
apply this style to another paragraph, insert your cursor in that paragraph, open the 
paragraph HUD, and select the style name from the drop-down menu. Your saved 
settings will instantly be applied.

Character HUD (expanded)

Paragraph HUD (expanded)

Align HUD
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2.2.10. Page halo
The page HUD looks just like the frame HUD and does exactly the same things, ex-
cept to the page itself rather than a frame. The page HUD is a good way to set a back-
ground for your page.

Flaps, 2.3. tabs, and palettes
The flaps hold most of Sophie’s functionality that you can’t get at through the halos 
and HUDs. Each flap has tabs in it; each tab has palettes. You can switch tabs by 
clicking on the tab name. By dragging the edges, you can change how big the tabs 
and palettes are. Palettes (and tabs) can also be dragged out to become free-standing 
windows: drag the title bar of the palette into the Sophie workspace. Drag it back into 
a flap when you want to put it back.

The left flap is generally concerned with the structure of your book. In the left flap 
you can find a list of open books, thumbnails of all the pages in your current book, 
and a list of the timelines in the current book. Click on the palette or tab that you’re 
interested in for a more detailed description:

Pages
Page palette • Page structure palette

Books
Books • Embedded books

Timelines
Timelines

Tools
Searching • Markers • Stickies • Search & Replace • Spellcheck

The right flap generally contains content that can be used to make books. In the right 
flap you can find book templates, the media that you’ve imported into Sophie, and 
components which can be dragged to the Sophie page. The right flap also has lists of 
styles created in Sophie, as well as some Sophie Server functionality. Click on the pal-
ette or tab that you’re interested in for a more detailed description

Library
Components • Book templates

The palettes in the resources 
tab in the right flap.

A palette that’s been detached.

Page HUD
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Styles
Page templates • Paragraph styles

Resources
Images • Audio • Movies • Text • Meta

Servers
Server • Server name • Books

OKI
Filter • Assets • Preview • Meta

There’s also a bottom flap, which becomes visible when you open a timeline. Other-
wise this flap isn’t used.

2.3.1. Pages tab
The pages tab contains palettes that have to do with pages in a Sophie books: the page 
preview palette and the page structure palette. The page structure palette is mini-
mized by default.

Page palette. The page palette shows thumbnails of every page in your book; the 
page you’re currently on has a red outline. If you make the flap wider, the thumbnails 
will get bigger. You can click on a thumbnail to go to that page; pages can also be 
dragged up and down to shuffle them. You can select multiple pages by shift-clicking 
other pages after you’ve selected a page. To delete a page from a Sophie book, select 
the page in the page palette and press DELETE or BACKSPACE. Be careful!

The page palette is also used when you want to apply a page template to a page. To 
do this, drag the page template you want from the page template palette to the page 
you want to apply it to. To insert a new page, drag the page template before, between, 
or after an existing page in the page palette.

Page structure palette. The page structure palette shows you a list of all the objects 
on your current page. When you select something on the page it is selected in the 
page structure palette’s list, and vice versa.

2.3.2. Books tab
The books tab contains palettes that have to do with the books you have open in So-
phie. 

Pages tab

Books tab
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Books palette. The books palette is a list of all the books you have open in Sophie. 
A book may be open, but its window may not be; to open a book’s window, drag the 
book out from the palette to the workspace. 

Embedded books palette. The embedded books palette is a list of all the books that 
are embedded in the book you currently have open and selected. To use an embedded 
book, you can drag it to the workspace to open its window or drag it to a page in the 
container book to embed it on that page.

2.3.3. Timelines tab/palette
The timelines tab only contains a single palette, the timelines palette. The timelines 
palette is a list of all the timelines in your current book; if you double-click one of 
them, you can edit that timeline in the timeline flap at the bottom of the Sophie win-
dow. To add a new timeline to a Sophie book, click either of the two buttons at the 
bottom of the timelines tab; either a single-page timeline or a page-spanning timeline 
will be added to your book and will be opened for editing in the timeline flap.

2.3.4. Tools tab
The tools tab contains a bunch of palettes that are used for editing and reading books: 
the searching palette, the markers palette, the stickies palette, and the spellchecker. 

Searching palette. The searching palette lets you search a Sophie document. When 
you enter a phrase in the search box, your current flow is searched; results are listed 
with context. Clicking on a result will take you to that page of the book.

Markers palette. The markers palette lists all highlights in the current Sophie book. 
You can delete a highlight by selecting its entry in this list and pressing DELETE. 
Clicking on an entry will take you to the page on which the highlight appears.

Stickies palette. The stickies palette allows you to make new stickies on a Sophie 
book. Pressing the “New Sticky” button will make a new sticky on the current page. 
The “Enable Stickies” checkbox toggles sticky visibility in the book.

Search & Replace palette. The search & replace palette lets you search for words or 
phrases in the text fields of your book and replace them. Enter a phrase to search for 
and one to replace it with; click Replace to replace the first result, or All to replace all 
occurences.

Spellchecker palette. The spellchecker palette allows you to spellcheck your book 
from the current flow. To start it, click in a flow and press the Next button. Timelines tab/palette

Tools tab
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2.3.5. Library tab
The library tab contains building blocks for Sophie books: different kinds of frames 
in the components palette and book templates in the book template palette.

Components palette. The components palette contains different kinds of frames that 
can be used in a Sophie book. Frames can be dragged from this palette to the page of 
a Sophie book or to the workspace (where they will create a new book). There are four 
types of frames: flow frame, non-flow frames, non-flow (template content) frames, 
and comment frames. Each does different things.

When a flow frame is full of text, a new page will be added to the Sophie book to 
hold the extra text. If there are two flow frames on a page, text can flow from one 
page to the next. If you hold down option or alt when dropping a flow frame on a 
page, you’ll create a new flow. You can adjust flow connections using Edit > Toggle 
Flow Connections.

When a non-flow or a non-flow (template content) frame is full of text, no extra 
page is created: the text doesn’t appear on the page, though it will if you resize the 
frame. Non-flow and non-flow (template content) frames behave in the same way un-
less they are on a template. If a non-flow frame is on a template, the frame can have 
different content on every page; if a non-flow (template content) frame is on a tem-
plate, the same content will appear on every page.

Comment frames allow readers to add comments to a book, much like a blog. 
Comment frames use Sophie Server; every reader who is reading a book with com-
ment frames will see all the comments attached to that frame by other readers when 
they look at the frame. 

Book templates palette. The book templates palette contains all the book templates 
that either came with Sophie or that you’ve saved. Book templates can be dragged to 
the workspace to create a new book using the book template, or dragged to the page 
of an open Sophie book to create a new embedded book.

2.3.6. Styles tab
The styles tab contains saved paragraph styles and page templates. Paragraph styles 
change the look of a paragraph; page templates change the look of a page.

Page templates palette. The page templates palette contains all page templates in 
the current book. By default, all books come with two page templates, “default page 
template” and “new blank page”. Page templates can be applied to a page by dragging 
the page template to the page’s thumbnail in the page palette. Pages can be added to 
a book that use a page template by dragging a page template before, between, or after 
pages in the page palette.

Styles tabLibrary tab
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Paragraph styles palette. The paragraph styles palette contains a list of all paragraph 
styles that have been saved in the current Sophie book. By default, every Sophie book 
contains one paragraph style, “default paragraph style”.

2.3.7. Resources tab
The resources tab contains all media that’s been imported into Sophie, separated into 
text, images, audio, and video. All of these objects can be dragged from their palettes 
to a Sophie book; if they are dragged to the workspace, a new Sophie book is started 
containing just that resource. The resources tab also contains the meta palette, which 
displays metadata on selected resources. 

Resources can be added to a Sophie book by dragging resources from the com-
puter to the resources tab, by using File > Import File, or by dragging the resources 
directly to the book page. Remote resources can also be added by using File > Link to 
URI (with a URI that points to the remote resource).

Images palette. The images palette contains a list of all images in the current book.

Audio palette. The audio palette contains a list of all audio files in the current Sophie 
book.

Movies palette. The movies palette contains a list of all movie files in the current So-
phie book.

Text palette. The text palette contains all text files that have been imported to the 
current Sophie book. To use a text file in a book, put a frame on the page – probably 
you’ll want a flow frame – insert the cursor in the frame, and then drag the text from 
the text palette to the cursor position and drop it.

Meta palette. The meta palette displays metadata about any resource that is selected. 

2.3.8. Servers tab
The servers tab displays palettes that have to do with Sophie Server. Sophie Server lets 
you save and open books on a remote server.

Server palette. This palette displays a list of all Sophie Servers that you’re currently 
connected to. To connect to a Sophie Server, use File > Add Server, or click “Add a 
Server” in the books palette of the servers tab.

Server name palette. This palette displays the name of the Sophie Server that you’re 
currently using.

Servers tab

Resources tab
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Server books palette. This palette displays a list of all books on the currently selected 
Sophie Server. To use a book on Sophie Server, drag it from this palette to the work-
space, which will open the most recent revision of the book.

If a book in the list has a “+” sign to the left of it, there are multiple versions of the 
book available. Click the “+” sign to see a list of the versions, which are arranged by 
date and time. You can drag out these old versions as well.

If the Refresh button is pressed, the server will be queried to see if new books have 
been uploaded by other users.

2.3.9. OKI tab
The OKI tab displays palettes that have to do with accessing OKI databases.

Filter palette. The filter palette lets you input the address of a server (in the Server: 
field) and a term to search for (in the Filter: field). Entering the address of a server 
and clicking Search will connect to an OKI server for the first time; filtering can be 
used after the server is connected.

Assets palette. The assets palette lists resources in the connected server once a server 
is connected. Resources can be dragged from this list to the page of the Sophie book 
you want to use them in.

Preview palette. The preview palette shows a preview of a resource when one is se-
lected in the list in the assets palette.

Meta palette. The meta palette shows metadata on a resource when one is selected 
in the list in the assets palette.

The 2.4. menu bars
The menu bars are only used sometimes in Sophie, but there are some important 
things that can only be accomplished via the menu bars. The Debug and Help menu 
aren’t really useful if you’re not a programmer, so those won’t be treated yet.

File2.4.1. 
The File menu generally contains things having to do with opening and saving So-
phie books and their contents.

File > New Book makes a new Sophie book. You’ll be prompted for the width and 
height of your new book. This command can also be triggered by command/control-
N. OKI tab
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File > Open Book prompts you for the location of a saved Sophie book file on your 
computer. You can do the same thing by pressing command/control-O.

File > Open Recent Books displays a list of recently used Sophie books. Click on one 
of them to open it. 

File > Open Notebook will open the notebook. This can also be done by dragging 
the notebook out from the books palette. The notebook is a blank Sophie book that’s 
always open in the background where you can save notes and resources you want to 
reuse. 

File > Close Book will close the Sophie book you currently have selected. You’ll be 
asked whether you want to save changes. You can also do this by pressing command/
control-W, or by clicking the little X button in the book’s title bar.

File > Close Window will close the window of the Sophie book you currently have 
selected but not the Sophie book itself: it will still be in the list of open books in the 
books palette. Use this if your workspace is too crowded. Command/control-shift-W 
will do this as well.

File > Save Book will save your current Sophie book. If you haven’t previously saved 
your book, you’ll be prompted for a name for your book. You can also do this by 
pressing command/control-S.

File > Save Book As will prompt you for a name to save a copy of your Sophie book 
as. This new file will become the working book file. You can also do this by pressing 
command/control-shift-S.

File > Save Book As To Sophie Server will upload your book to a Sophie Server. You 
should save your book locally first, as the name that your book has is the name that it 
will be uploaded to the Sophie Server as. If you’re not currently logged into a Sophie 
Server, you’ll be prompted to login to a server.

File > Save Book Template As will save your book as a book template; you’ll be 
prompted for a place to save the book template, which by default is the directory in 
which Sophie looks for book templates. Saving your book as a book template will 
erase all text and all pages but the first one. If the book template is saved in Sophie’s 
default book template directory, the new book template will be listed in the book tem-
plates palette.

File > Publish Book For OLPC exports your Sophie book in a form which can be used 

The File menu 
(on a Mac)
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on OLPC computers. Books published in this way have the extension .sophie.

File > Export Highlights will export any highlights you may have made in your book 
to a file that can later be imported by another Sophie user with the same book.

File > Import Highlights will import previously exported highlights.

File > Export Book Stickies As will export any stickies that exist in your book as a file 
that can be imported by another Sophie user with the same book.

File > Import Book Stickies will import a previously exported stickies file.

File > Import URI will prompt you for the URI of a remote object that can be used in 
a Sophie book. This object will be downloaded and included in the current Sophie 
book’s resources.

File > Link To URI will prompt you for the URI of a remote object that can be used in 
a Sophie book. The object will appear in Sophie’s resources, but the object will not be 
downloaded until the reader looks at it on the page. Use this if you want your Sophie 
book to remain small in size.

File > Import File does the same thing as dragging an object from your computer’s 
desktop to Sophie’s resources. You’ll be prompted for the location of resources that 
you want to use in Sophie.

File > Link To File will prompt you for the location of an object on your computer. 
While you’ll be able to use the object in your Sophie book, it won’t be imported into 
your Sophie book. You might use this option if you have an enormous movie on your 
computer that you want to use in several Sophie books.

File > Add Server will prompt you for the URL for a Sophie Server. When a Sophie 
Server is connected to, its contents will appear in the server tab on the right.

File > Export Resources In Book will ask you for a location; all the resources in your 
Sophie book will be exported to that location. 

Edit2.4.2. 
The Edit menu generally contains things having to do with manipulating objects on a 
Sophie page. 

The File menu 
(on a Mac)
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Edit > Undo undoes the last thing you did in Sophie. You can also do this by pressing 
command/control-Z.

Edit > Redo redoes the last thing you undid in Sophie. Use this if you undid some-
thing by mistake. You can also do this by pressing command/control-Y.

Edit > Cut removes the selected text, frame, or timeline event and copies it to the clip-
board for later pasting. You can also do this by pressing command/control-X.

Edit > Copy copies the selected text, frame, or timeline event to the clipboard for later 
pasting. You can also do this with command/control-C.

Edit > Paste will paste whatever you have on the pasteboard at the current insertion 
point. The current insertion point for text is where the cursor is. Frames will be past-
ed at the same location on the current page. Timeline events will be pasted starting at 
the current playhead position. You can also do this by pressing command/control-V.

Edit > Clear will delete the currently selected frame, text, or timeline event and not 
copy it to the clipboard.

Edit > Highlight Text. If text is selected, choosing this (or pressing command/control-
M) will highlight the selected text.

Edit > Spellchecker will look for the next misspelled word from the current cursor 
insertion point in text.

Edit > Test Mode will switch Sophie into Test mode (if in Author mode), or into Au-
thor mode (if in Test mode). You can do the same thing by checking the Reader Mode 
box in the status bar of any Sophie book or by pressing command/control-T.

Edit > Auto Save Template will automatically move flow frames to the page template 
when pages are created automatically by flow frames. This is still experimental.

Edit > Copy Selection As Reference will copy a reference to the selected part of 
the Sophie book to the clipboard. This is only partially implemented in RC7 and 
shouldn’t be used.

Edit > Paste Reference To Selection may open a reference to a selected part of a 
Sophie book that’s previously copied, though this is only partially implemented and 
probably won’t work.

The Edit menu (on a Mac)
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Edit > Toggle Flow Connections will make flow connections visible. Different flows 
are given different colors; you can drag the connections between the different flows 
on a page back and forth.

Edit > Toggle Rulers will make the Sophie rulers visible on the current book.

Keyboard shortcuts2.5. 
Here is a list of keyboard shortcuts you can use in Sophie. Command/control means 
that you should press the command key on a Mac or the control key on a PC.

command/control-A. If text is selected, this selects all text in the current flow. If no 
text is selected, this selects all objects on a page.

command/control-C. If text is selected, this copies the text to the clipboard. If no text 
is selected, this copies any objects that are selected to the clipboards

command/control-D. If an object or event on a timeline is selected, the object or event 
is duplicated.

command/control-F brings up the find dialogue.

command/control-G. If more than one frame is selected, the frames are grouped.

command-H. On a Mac, this hides the Sophie application.

command/control-M highlights the selected text. 

command/control-N creates a new book.

command/control-O opens a book.

command/control-Q quits Sophie. If books are open, you’ll be asked whether to save them.

command/control-S saves the current Sophie book.

command/control-shift-S saves the current Sophie book, prompting for a filename.

command/control-T toggles test mode.

command/control-U. If grouped frames are selected, they are ungrouped.
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command/control-V. If there is an insertion point in text, this pastes whatever is on 
the clipboard at that point. If there is no insertion point in text, whatever is on the 
clipboard is pasted onto the current page.

On the Mac, if you copy something on the Mac desktop – an image, audio, video, 
or supported text file – and then paste it into Sophie, the object will be imported into 
the current Sophie book.

command/control-W closes the currently selected Sophie book.

command/control-shift-W closes the currently selected window of a Sophie book.

command/control-X. If text is selected, this cuts the text (copying it to the clipboard & 
deleting it). If no text is selected, any selected objects are cut.

command/control-Y redoes the last undone operation.

command/control-Z undoes the last operation. This only works with text.

command/control-RETURN. If the cursor is inserted into a flow frame and this is 
pressed, a page break is inserted.

DELETE/BACKSPACE. If a frame or a timeline event is selected, the frame or timeline 
event is deleted. These can also be used in most palettes that contain lists. 

arrow keys. If a frame is selected, the frame is moved one point in the direction 
pressed. In text, the cursor is moved. If nothing is selected, the left and right arrows 
will go forwards or backwards in pages.

shift-arrow keys. If a frame is selected, the frame is moved 10 points in the direction. 

PageUp/PageDown go forward or backwards a page.

command-shift-; (Mac) / F7 (Windows/Linux) finds the next spelling mistake.
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Special keyboard interactions2.6. 
There are a few cases in Sophie where keys can be pressed to change interactions. 
These include:

Holding down •	 option (on a Mac) or alt (on a PC) when dropping a flow frame. 
This will cause the dropped frame to start a new flow. 

Holding down •	 control when dropping a book inside another book. If this is done, 
the dropped book is embedded in the book it is dropped on, rather than linked.

Selecting a movie on a timeline and pressing •	 control will toggle whether the movie 
is visible on the page when the movie is not playing. 

In general, when selecting, pressing •	 command (on a Mac) or control (on a PC) will 
extend the section. This can be used with frames on the page, resources listed in a 
palette, and events on a timeline. 

If you select one resource in a palette, then hold down •	 shift and select another one, 
all the resources between them will also be selected. 

Selecting one page, then holding down •	 shift and selecting another page will select 
all the range of pages.

Holding down •	 shift while dragging the corner of a frame will resize the frame pro-
portionately.

When typing, •	 command-click (on a Mac) or control-click (on a PC) will select the 
frame of the text and bring up the frame halos.
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Working with books3. 

Making a new book3.1. 
There are several ways to make a new Sophie book. You can go to the File menu and 
choose New Book, or you can press command/control-N. Both of these options will 
present you with a dialogue box asking for the size of the book you want. Sophie 
books can be as big as you like; however, if the book is bigger than the Sophie win-
dow, it will have scrollbars and you won’t be able to see all of it at once.

Another way to create a new Sophie book is to drag a frame or a resource to the 
workspace. A new book will be created containing just that frame or resource.

Using book templates3.2. 
You can also create a new Sophie book by dragging a book template to the workspace. 
Book templates are found in the book templates palette in the books tab; some book 
templates come with Sophie, and some are found in your local book templates direc-
tory. Book templates contain frames and backgrounds; it’s easier to start with a book 
template than it is to start from scratch.

If you drag a book template onto a page of another Sophie book, a new book will 
be created that is inside of the existing book. This is called an embedded book. 

Making book templates3.3. 
To make a book template, go to the File menu and choose Save Book Template As. By 
default you’ll be taken to the default book template directory; book templates that are 
saved in this directory appear in the book templates palette. When a book is saved as 
a book template, most content is deleted; essentially a book template is a collection 
of blank pages. Book templates can’t contain links or timelines in Sophie 1.0; if you 
try to save a book as a book template that contains links or timelines, a warning will 
appear.

The new book dialogue box
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Working with 4. frames

“Frame” can mean both objects on a Sophie page – like images and movies – and the 
kind of frame that you drag out and fill with text. Both types of frame have common 
properties: when you click on the outside of the frame, the same halos pop up. All 
frames have a frame halo (a little square), a content halo (a little house), and a link 
halo (a little chain). In addition, all frames have a clock halo which can be dragged to 
a timeline to put the frame on a timeline. In the upper right corner of every selected 
frame, there’s a green square which can be dragged to rotate the frame. 

If your cursor is in text in a frame, you won’t see the frame halos, you’ll see the text 
halos. You can select the frame and get to the frame halos quickly by holding down 
the command key (on a Mac) or the control key (on a PC) and clicking anywhere in 
the frame. Or you can just click the outside edge of the frame.

Changing the 4.1. size and position of a frame
The orange edges of a selected frame can be dragged back and forth to change the 
width and height of a frame; dragging a corner will change both width and height 
at the same time. (Hold down the shift key while you drag to keep width and height 
proportional).

Frames can be moved on the page by selecting them and using the arrow keys; 
each time you press an arrow key, the frame will move by 1 point. If you hold down 
shift and an arrow key at the same time, the frame will move by 10 points. You can 
usually move a frame by clicking inside it and dragging with the mouse; if the con-
tent of the frame is text, drag the frame by the little “+” sign to avoid inserting your 
cursor in text.

You can also change the size and position of a frame by using the content halo. 
The top section of the content halo contains the frame’s current position on the page, 
width, and height. There’s a little grid of dots; one of them is lit up. The lit-up dot is 
the frame’s control point: if that dot is in the center, the X and Y values for the frame 
are of the center of the frame. If the control point is the upper left, the X and Y values 
are for the upper left corner of the frame. The control point also controls how the 
frame is resized: if you make a frame twice as wide and your control point is the cen-
ter, the frame will stay centered in the same place on the page and get wider. If your 
control point is on the left and you do the same thing, the frame’s left side will stay in 
the same place; the right side will jump to the right, becoming wider.

By default, the width and the height of a frame change proportionately. That is, if 
your frame is 100 points wide and 50 points hight and you double the width to 200 

The content HUD for a frame

Using edges & corners to resize frames.



22

points, the height will double as well to 100 points. To the right of the width and 
height is a little chain; if you click this, the chain will break, meaning that width and 
height are no longer proportional. When the chain is broken if you change your 100 
x 50 point frame to 200 points wide, the height will stay at 50 points. Click the chain 
again to change it back to proportional settings. 

Changing wrapping properties 4.1.1. 
If you have a frame full of text and you drop an image over it, you’ll see that the text 
will reflow itself to wrap around the image. While this is the default setting, you can 
change this setting for every frame on a Sophie page: it’s possible that you want your 
image to obscure your text. There are three buttons that control wrapping; they’re be-
low the x- and y-coordinates and the width and height in the content halo. By default, 
the one in the middle is selected. This means that text will flow around the frame you 
have selected. If you select the icon on the right, text won’t flow around the frame 
you’ve selected. If you select the icon on the left, text will flow around the frame 
you’ve selected and not appear to the left or right of the frame.

4.1.2. Multiple selection, grouping, and aligning frames
You can select more than one frame at a time by selecting one frame than holding 
down command (on a Mac) or control (on a PC) and clicking another frame. You can 
repeat this to select multiple frames. Multiply-selected frames can be dragged about; 
you can change their size, though this may have strange effects. If you want certain 
frames to always move together, you can press command/control-G to group them. 
Whenever you select one of a grouped frame, other frames grouped with it will also 
be selected. Frames can be ungrouped by selecting the group and pressing command/
control-U. 

When multiple frames are selected, the align halo appears. If you click the align 
halo, the align HUD will appear. The align HUD contains six different buttons, 
which will align frames on different axes. The top left button, for example, will make 
the top edges of all frames start at the same place: the top edge of the first-selected 
frame, which is given a red outline.

Setting borders and fills4.2. 
To set borders and fills, open the frame halo, the leftmost of the halos. You are pre-
sented with options for filling, borders, and drop shadows for your frame. Not all of 
these work all the time: for example, if you have a movie, you can put a drop shadow 
and a border on it, but not a fill. It already has a fill: the movie itself. If you’re using 
an image and it’s has transparency, however, you can change the fill on the image: the 
fill you choose will appear behind the transparent parts of the image.

There are five fill styles, which can be chosen from the drop-down menu: none, 

The wrapping controls

Multiply-selected frames
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solid, radialGradient, linearGradient, and pattern. None means the frame has a trans-
parent background. Solid means the frame has a solid-colored background. Click the 
square next to the drop-down menu to choose the color; the default is white. Radial 
and linear gradients are mixes of color; you can click the square next to the fill style to 
set up how the gradient will work. And pattern means that an image will be used as 
the background for the frame. Drag an image from the resources into the white box 
next to the drop-down menu; you can click on the box to set up how the background 
pattern is displayed.

Beneath fill styles are border controls: you can choose a width and color for your 
frame’s border. By default, frames have no border, so the default width is 0 pts; the 
default color is black. Enter a value (in points) for the width of the border you want 
and click the black square to change the color of the border.

At the bottom of the frame HUD are the drop shadow controls. By default, frames 
have no drop shadow, but you can add one by changing the drop shadow offsets. 
There are two values: the horizontal offset and the vertical offset. If either of these is 
not zero, a drop shadow will appear. (These values can be negative if you want to have 
a drop shadow that is to the left or above your frame.) Beneath the offset values is a 
slider that controls the hardness of the drop shadow: if you slide it all the way to the 
left, the drop shadow will be hard and square, if you slide it to the right it will become 
fuzzy. The square to the right of the slider sets the color of the drop shadow; by de-
fault it’s black and slightly transparent.

Making links with the 4.3. link halo
Frames can be links just like text. To make a frame a link, select the frame and click 
the link halo to open the link HUD. The link halo is described here.

Once you’ve made a frame a link, the link color halo appears to the right of the link 
halo. If you open this, you’ll see something that looks very much like the frame HUD. 
At the top of the HUD is a drop-down menu that lets you choose “normal”, “over”, 
and “pressed”. “Normal” is selected by default: the part that looks like the frame HUD 
shows what the frame and border settings for the frame are normally. If you choose 

“over,” you can change how the frame, border, and drop shadow look when the reader 
moves their mouse over the frame. If you choose “pressed,” you can change the set-
tings for how the frame looks once the link has been triggered.

There are also four boxes at the bottom of this HUD: one for normal, one for “over” 
(what the reader sees when their mouse is over the link) one for “pressed” (what the 
reader sees when the link is being triggered) and one for “visited” (what the reader 
sees after the link was triggered). You can drag images into these boxes; they will be 
used as the background for the frame when the visitor moves the mouse over the 
frame, activates the link, or has triggered the link. Effectively, this lets you make but-
tons. This does exactly the same thing as using an image for a pattern in the different 
states of the link; if you’d like to make buttons that way, you can do that.

The color picker

Pattern controls

Gradient controls

The link color picker
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Working with 5. text

Using the character halo5.1. 
The character halo appears when your cursor is in text; it’s the left-most halo. Click-
ing it opens the character HUD. The most prominent setting is the font you’re cur-
rently using, which is in a drop-down menu. You can choose another font from this 
list. In the character HUD are also your font’s size; you can pick a size from the drop-
down menu, or you can type in your own size. If the font you’ve chosen has a bold or 
an italic face, you can press the “B” or “I” button to choose a bold or italic version of 
the font. The box next to the font name is the color of the type, black by default; if you 
click on this, you can choose another color for the font.

If you open up the halo move by clicking the down arrow at the bottom of the 
HUD, you’ll see more options. The box on the right selects the background color of 
the text. By default this is transparent; if you choose a more opaque setting, your text 
will appear highlighted. The “Reset Style” button removes any character setting that 
is different from the paragraph’s character setting.

If you have text selected, the changes you make in the character HUD will only af-
fect that selection. If you don’t have text selected, changes made in the character HUD 
will affect anything you write immediately after making changes in the HUD. If you 
want to change the layout of an entire paragraph, you should use the paragraph HUD.

Using the 5.2. paragraph halo
Clicking the paragraph halo opens the paragraph HUD. The paragraph HUD con-
trols text settings for entire paragraphs: any changes that you make in the paragraph 
HUD will be made not just to what you have selected but to the entire paragraph that 
the selection is in. You don’t need to have any text selected to use the paragraph HUD 

– it’s enough that your cursor just be inserted into text. If you have text selected across 
paragraphs, all changes made in the paragraph HUD will be applied to all paragraphs 
even partially selected.

At the top of the paragraph HUD is the paragraph style name, which is by default 
“default.” Paragraph styles contain all the formatting information for a paragraph; they 
can be saved so that you can reuse them. If you want all your headers to be centered 
and in bold type, and all your body text to be left-aligned and in regular type, you 
could use saved paragraph styles to make sure they’re alike. You don’t have to use 
saved paragraph styles if you don’t want to; but if you don’t, you’ll have to reformat 

The paragraph HUD

The character HUD
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paragraphs by hand. To use a paragraph style that’s already been saved, pull down the 
drop-down menu and select the style in the list. To save your current paragraph for-
mat as a saved paragraph style, click the little disc to the right of the drop-down menu. 
You’ll be prompted for a name; if you choose a name that’s already taken, you’ll be 
replacing that style.

Beneath the style-saving drop-down box, there are the linespacing controls. Line-
spacing is how much space there is between the lines in a paragraph. (This isn’t the 
same thing as adding space above or below a paragraph: there’s a separate control 
for this.) You can control linespace in different ways: you can use a multiple of lines 
(single or double-spacing); single spacing is the default. Or you can choose a unit 
of space (in points, picas, or millimeters) if you want a fixed amount of linespacing. 
First choose your unit (or keep it the default “line”); then change the multiple (for 
line spacing) or the height (for fixed spacing).

Below the linespacing controls on the left is the first-line indent, which controls 
whether your paragraph is indented. This is measured in points. This value can also 
be negative if you want to have your paragraph outdented (as in a bulleted list, for 
example). If you want to do this, you should have a positive value in your left indent 
(see below). 

To the right of the first-line indent are the paragraph alignment controls. There 
are four buttons: for left-aligned, center-aligned, right-aligned, and fully justified. The 
default is left-aligned. 

If you open up the paragraph style palette by clicking the down arrow at the bot-
tom of the paragraph, more controls become visible. From the top and left to right the 
first four are left indent, right indent, space above paragraph and space below para-
graph. Below those are controls for drop caps, which don’t work, and the next style 
setting, which also doesn’t work.

If you open up the paragraph style HUD even further, you’ll see character settings 
that look just like the character HUD. Changes made to this section are applied to the 
entire paragraph, not just the selected text. 

Using 5.3. paragraph styles
At the top of the paragraph HUD is the paragraph style name, which is by default 

“default.” Paragraph styles contain all the formatting information for a paragraph; they 
can be saved so that you can reuse them. If you want all your headers to be centered 
and in bold type, and all your body text to be left-aligned and in regular type, you 
could use saved paragraph styles to make sure they’re alike. You don’t have to use 
saved paragraph styles if you don’t want to; but if you don’t, you’ll have to reformat 
paragraphs by hand. To use a paragraph style that’s already been saved, pull down the 
drop-down menu and select the style in the list. To save your current paragraph for-
mat as a saved paragraph style, click the little disc to the right of the drop-down menu. 
You’ll be prompted for a name; if you choose a name that’s already taken, you’ll be 

The list of paragraph styles

Replacing a paragraph style
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replacing that style.
Saved paragraph styles appear in the paragraph styles palette in the styles tab. Dou-

ble-clicking on one of these names will allow you to change the name. If you select an 
unused style in this palette, you can press DELETE or BACKSPACE to delete the style 
from the book.

Using the 5.4. link halo
To make a link out of text, you need to select text. When this is done, the link halo 
appears to the right of the paragraph halo. Click it brings up the link HUD. The link 
HUD includes three windows that are used to represent these three parts of the link. 
The top drop-down menu lists possible triggers. The middle drop-down menu lists 
possible actions to take. And the third drop-down menu changes depending on what 
kind of link is selected. If the action is to open a URL, you can type in the URL in the 
third box. If the action is to open a timeline, you can drag the timeline from the time-
line palette to the third box. If the action is to show or hide a frame, drag the little 
anchor near the box to the frame you want to show or hide.

The “+” and “–” at the bottom of the link HUD allow you to make more complex 
links: the same frame or text can be part of several different links.

Searching text5.5. 
There are three different ways to search text in Sophie. There is the status bar search 
window, the searching palette, and the search & replace palette.

The status bar search is the simplest way to search text in Sophie. Enter text in 
the field and press the down button (to search forward from where you currently are 
in text) or the up button (to search backwards from where you currently are in text). 
If the text you’re searching for appears in your book, you’ll be taken to the page on 
which it appears and the text will be highlighted. You can press the buttons again to 
find another occurrence.

The searching palette, in the tools tab, gives you a list of results with some context. 
Type in the text you’re looking for in the field at the top of the palette and hit ENTER. 
A list of all occurrences in text will be provided in the palette; to go to one of them, 
click it in the list. You can press command/control-F to get to this palette quickly.

The search & replace palette is used to replace text. If you enter text in the search 
field then press ENTER, the next occurence of the text will be highlighted. If you en-
ter something in the replace field, you can use the Replace button to replace the first 
found instance; pressing the All button will replace all instances of that text.

The link HUD

The status bar search
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Using the 5.6. spellchecker
Pressing command-; or going to Edit > Spellchecker will look for the next misspelled 
word from the current cursor insertion point in text; if found, the misspelling will be 
selected. More advanced spellchecking can be done with the spellchecker palette, in 
the tools palette.

Using 5.7. multiple flows
By default, every flow frame that you drag to a page uses the same flow. So if you drag 
out a flow frame, put a lot of text in it, and put another flow frame on the same page, 
the text will flow from one frame to the next, because it’s assumed that they are con-
nected.

This isn’t always what you want to do. Imagine that you have a five-page story in 
English; you want to put it in a book where it will appear side by side with the same 
story in Spanish. For this situation, you want to use two different flows. The English 
story might go through a frame on the left on page 1 to page 5; the Spanish story 
might go through a frame on the right on page 1 to page 5. The English story uses 
one flow while the Spanish story uses another.

To create a flow frame that uses another flow, hold down the option key (on a Mac) 
or the alt key (on a PC) when you drop the frame on the page. A new flow will be cre-
ated. If you don’t hold down the option or alt key, the flow frame that is created will 
use the existing flow. 

Another way of manipulating multiple flows is by using the flow halos. You can 
do this by going to Edit > Show flow connections. When this is turned on, every flow 
frame will have a colored border around it; different flows will have different colors. 
If you have two frames on the page that use the same flow, an arrow will be shown 
connecting the two frames in the direction of the flow. The arrows come from a little 
box at the lower right of every frame; you can drag from this box to another frame to 
connect the frames. If the frames have different flows when you do this, the second 
one will be changed to the first flow.

Using multiple flows
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Working with 6. media

Adding 6.1. resources to Sophie
To add resources to a Sophie book, drag them into Sophie’s window. If resources 
are dropped on a page, they will appear on the page and in the book’s resources; if 
resources are dropped onto the library tab, they’ll be added to the resources but won’t 
immediately appear on the pages of the book. You can also add resources to Sophie 
by using File > Import Resources, which will prompt you to find resources to add to 
Sophie.

Not all resources have to be on your computer: you can use resources that are on 
the Internet if they are the kind of file that can be imported to Sophie (an MP3, for 
example). To do this, you need to know the URL for the file. Go to File > Link to Re-
source and enter the URL. An icon for the resource will be added to the resources tab 
in the appropriate palette; you can drag it from there to the page. A good reason to do 
this is if your book uses enormous resources but you don’t want your book file to be 
enormous. You might also do this if you are using resources that are being updated 
outside of Sophie.

Using 6.2. time-based media
Time-based media (audio and video) work slightly differently from other sorts of me-
dia. When you select one of these on a page, you’ll see a halo to the right of the link 
halo, the time-based media halo; clicking it opens the time-based media HUD. This 
is a simple HUD: it includes checkboxes that ask if you want the media to play when 
shown and whether a controller should be shown. If “play when shown” is checked, 
the media will start playing as soon as the page of the book that it appears on is 
opened. (What this checkbox does, actually, is to create a link: open the link HUD to 
see what it does.) If “show controller” is checked, play and pause buttons are shown 
that the reader can use.

It’s also worth noting that time-based media by default comes with links built into 
them: they’re set so that if you double-click them they’ll play, and if you single-click 
them they’ll stop. If this isn’t what you want them to do, you can delete these two 
links.

The resources tab

The time-based media HUD
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Working with 7. pages

Using the 7.1. page structure palette
The page structure is used for more advanced control of frames on pages. The page 
structure palette lists four different things:

The •	 page entry. This is at the top of the list; everything else appears below the 
page in the entry. This also displays the page number. If the page has been 
changed via the page halo and the page template has not been saved since, there’s 
an asterisk next to the page number. Selecting the page in the page structure pal-
ette makes the page halo appear on the page.

•	 Frames that are on the page. Audio, movies, and images are identified by their 
filenames; text frames are identified by a snippet of the text in the frame. Frames 
on the page are also distinguished by number (starting from 1 and incrementing); 
text frames are split into “flow” and “nonflow”. Frames are listed in the z-order in 
which they appear; the top frame in the list appears above frames lower in the list. 

An entry for the •	 page template being used. This is in the form “default page tem-
plate (layout 1)” where “default page template” is the page template currently being 
used. If the frames on the template on this page are different from the frames on 
the saved page template (if there are more or less frames, or if the frames have 
been moved), there is an asterisk next to the entry.

•	 Frames on the template. If frames are listed below the template entry, the frames 
are on the template. These frames are listed in z-order. If a frame has been modi-
fied from its definition on the template, or if a frame on the template doesn’t exist 
on the saved template, there’s an asterisk next to it.

Depending on what (if anything) is selected in the page structure palette, buttons ap-
pear at the bottom of the palette with possible actions. These buttons are:

Nothing selected in palette.•	  “Save page as template” buton.

Page selected.•	  “Save page as template” button.

Frame not on •	 template selected. “Move to template” button and “Save page as 
template” button.

Layout selected•	 . “Save changes to template” button, “Reset to template defaults” 
button, “Save as template” button.

Frame on template selected.•	  “Reset content overrides” button.

The page structure palette with 
nothing selected – the same  
buttons appear that appear when 
the page is selected.

The page structure palette with 
a frame on a page selected
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So we have in total seven buttons:

Save page as template.•	  The user is prompted for a name for the page template. 
This button moves all frames on the page to the template. If the user has chosen 
the name of an existing page template, that page template is replaced. (Save as 
template does the same thing.)

Move to template.•	  This button moves a frame that is not on a template onto the 
current template in use on the page. The page template is not saved; if you want to 
do that, choose the “Save changes to template” button.

Move from template.•	  This button is only useful if a frame has been moved to the 
template with the “Move to template” button and you decide that you don’t want 
the frame on the template before you save the changes to the template. If you 
press this button, the frame will be moved off the template.

Save changes to template.•	  If objects on the template have been modified (or delet-
ed), this button saves the changes to the currently used template. If changes have 
not been made to the template on the page, pressing this button does nothing. 

Reset to template defaults•	 . This button undoes all changes done to frames on the 
template (or frames added to the template before saving changes) and returns to 
the defined template.

Reset content •	 override. If a frame that is on a template has been modified from 
the way it is on the saved template, pressing this button will restore it to the tem-
plate defaults.

The two kinds of non-flow frames behave differently when they are on a template. 
When a non-flow frame is on a template, the frame and its content appear on every 
page that uses that template; however, the frame can have different content on every 
page. If a non-flow (template content) frame is on a template, every page that uses 
that template will have exactly the same frame. Editing the content on any page that 
uses that frame will change the content on every page that uses that template. (Com-
ment frames work the same way: comment (template content) frames have exactly 
the same content on every page in which the template that holds them is applied.)

Using 7.2. page templates
A page template is a collection of frames that you want to appear on more than one 
page. The page template also contains the page background. Page templates are used 
to save time. If you want a header graphic at the top of every page and a footer graph-
ic at the bottom of every page, you could manually place the graphics on every page 
in your book. But it’s much faster just to apply a page template which automatically 
places those graphics. Frames that are on a page can be moved to the page template; 
frames that are on the page template can be removed from the page template.

The page structure palette with 
the page template selected 

The page structure palette with a 
frame on the template selected.
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Every page in Sophie uses a page template, though a page template may not have 
any frames on it. You can see which page template your page is using by going to the 
page structure palette. If your page uses frames that are part of the page template, 
they’ll be listed under the page template.

If a Sophie book is built from a book template, it may come with a number of 
page templates. A Sophie book that’s built entirely from scratch comes with two page 
templates: “default page template,” which is the page template used by the first page 
in the book by default, and “blank page template”, which is a blank page. The page 
templates that are in your book are listed in the page templates palette, which is in 
the styles tab.

7.2.1. Applying page templates
To apply a page template to a page, drag the page template you want to use to the 
page in the page view palette to which you want to apply the page template. The page 
thumbnail will turn red when the dragged page template is over it; drop it and the 
page template is applied to the page.

If you want to apply the same page template to multiple pages, click the first page 
in the page template, shift-select all additional pages you want to change, then drag 
the page template you want to use to the page palette. The pages will light up red.

7.2.2. Adding pages
Pages are added to a Sophie book in exactly the same way that page templates are ap-
plied to pages. Select the page template of the page you want to add (or “blank page 
template” if you want to add a blank page) and drag it to the list of pages. Instead of 
dropping it on a page, drop it before or after a page: a red line will appear showing 
the place in the book where the new page will be added.

(Pages can also be added by a flow frame that’s full. When a page is created this 
way, the new page will have the page template of the page that created it.)

Making & MODIFYING page templates7.2.3. 
To make a new page template, or to change an existing page template, use the page 
structure palette. See the section on that for more information on how this works.

Adding a new page by 
dragging a page template 

between two existing pages

Applying a page template to a page
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Working with 8. embedded books

Creating 8.1. embedded books
Embedded books can be embedded in two different ways. A fully embedded book 
lives entirely inside the parent book: when you send the parent book to someone, the 
embedded book goes with it, like a media resource that’s in the book. A linked em-
bedded book doesn’t live inside the parent book: while it displays in the same way as 
a fully embedded book, it lives somewhere else. If you send someone a parent book 
without the linked embedded book, the linked embedded book won’t show up.

Creating fully embedded books8.1.1. 
A book can only be fully embedded in another book if it is made from a book tem-
plate. To make a book template, create a book and save it as a book template in the 
default book template directory. The book template that you’ve created will appear in 
the book template palette. From there, it can be dragged to the page of the book you 
want to embed it in. Text or media that’s inserted into an embedded book created in 
this way will be saved inside of the container book. 

Creating linked 8.1.2. embedded books
To create a linked embedded book, open both the book you want to embed and the 
book that will be the container book. Drag the icon for the book you want to embed 
from the books palette to the page of the container book on which you want the em-
bedded book to appear. Both books are still independent: if you make a change in the 
embedded book when the container book is closed, the changes will be visible the 
next time you open the embedded book from the container book.

If you want to give the container book to someone on a different computer, if they 
are going to use the embedded book, you’ll need to send it along too.

If you hold down the control key when you drag a book from the book palette to 
the page of the book, Sophie will attempt to convert the book into a template so that 
the book can be fully embedded. This process will strip out all content of the embed-
ded book. This may not work; if it doesn’t, an error message will appear.

The embedded books palette of a 
book with many embedded books
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Displaying 8.2. embedded books
Embedded books can be displayed two ways: on the page, like an image or a movie, 
or in their own window. The same book can be embedded in multiple places in the 
same book.

If you’ve created an embedded book by dragging a book or book template to the 
page of another book, it will display on that page by default. This doesn’t need to be 
the case: you can select the embedded book on the page (by clicking its frame) and 
press DELETE or BACKSPACE to remove it from the page. The embedded book will 
still be in the embedded books list; you can drag it from there to the same page or 
another page in the book. 

A book that’s embedded on a page of a parent book can be moved around the page 
like any other object. To turn the pages of such a book, the reader needs to click in the 
book, then use the arrow keys to turn the pages.

An embedded book can also be opened in a separate window. To do this, make a 
link; for the link action, choose “Open embedded book”. Then drag the embedded 
book from the embedded book palette to the third window in the link HUD. When 
the link is triggered, the embedded book will be opened in its own window. 

An embedded book in its own window.
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Working with 9. timelines

The timeline 9.1. interface
There are two major parts of the timeline interface in Sophie: the timelines palette 
(in the timelines tab, in the left flap) and the timeline window, which appears when a 
timeline is opened. There’s also the clock halo on objects on the page, which allows 
objects to be attached to a timeline. The link HUD contains commands related to 
starting and stopping timelines.

The timeline palette lists all timelines in the book. Double-clicking an entry in 
this list will open the timeline window for that timeline; pressing DELETE or BACK-
SPACE while you have a timeline selected will remove the timeline from the book.

At the bottom of the timeline palette are two buttons, which let you add new single 
page or multiple page timelines. 

Kinds of timelines9.2. 
There are two different kinds of timelines. A single-page timeline contains only ac-
tions which are used on that page. A multiple-page timeline turns certain pages at 
certain points in time. Use a multiple-page timeline when you’re constructing a slide-
show where pages turn to audio or video accompaniment; use a single-page timeline 
for most other uses.

Using single-page timelines9.3. 
Single-page timelines are the simplest kind of timelines. When you create a new one, 
the timeline window will open at the bottom of the screen. The timeline window is 
a special kind of palette in a flap; it can be made shorter or taller and can even be 
pulled out to appear on its own window if you want. At the top of the timeline win-
dow are controls; at the bottom are channels where media or events can be found.

The controls for the timeline are fairly basic. On the left is the timeline’s name; 
this can be edited to rename the timeline. To the right of the name are rewind and 
play/pause button. Clicking these buttons rewinds the timeline or plays it; clicking 
the play/pause button when the timeline is playing will pause the timeline. Next to 
the play/pause button is the current position in time of the playhead. There are also 
boxes for the start, end, and duration of the selected clip.

Above the channels is a playhead, which can be dragged back and forth; if there are 

The timelines tab
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different events visible at different points in the timeline, what’s visible on the page 
will change as the playhead is moved. As the playhead is moved, the current time po-
sition in the controls above will also change.

Above the playhead is the slider, which can be used to change the zoom and area 
of the timeline being viewed. By default, the slider is as wide as the timeline window, 
which means that all of the timeline is visible. The more you narrow the slider, the 
more the timeline is zoomed in. You can then move the slider left and right to see 
earlier or later positions in the timeline.

Media and events appear in the channels on the timeline. To add media on the cur-
rent page to your timeline, select the object, and drag its clock halo to the position on 
the timeline where you want it to appear. You can also add media to timelines by drag-
ging directly from the resource palettes to the timeline; when you do this, the object is 
immediately added to a page. A piece of media can only appear on a timeline once. 

If an image or a frame is added to a timeline, it will be visible for the time that its 
event on the timeline appears across. That is, if you have a picture that’s on a time-
line from 1:00 to 2:00, when the timeline plays the picture will not be visible for the 
first minute. It will be visible as the timeline plays from 1:00 to 2:00; if the timeline 
goes past 2:00, it will be invisible again. If audio or video appears on a timeline, 
when the timeline is played the audio or video will be played. The video will only be 
visible when it is playing; if the video does not stretch across the entire length of the 
timeline, the video’s frame on the page will be invisible when the video is not playing.  
(If you control-click on a video’s event on a timeline, you can toggle whether or not it 
is visible when the event is not being played.) You can get a good feel for this by put-
ting some objects on a timeline and dragging the playhead back and forth: when the 
playhead is over the events on the timeline they become visible. When it’s not over 
them, they’re invisible.

If you drop a piece of media over an existing channel on the timeline, it will be in 
that channel; if you drop it below an existing channel, a new channel will be created 
to hold that event. Once an event is in a channel, you can move it to another channel 
by dragging it from one channel to another (or to the bottom of the timeline window 
to create a new channel). It doesn’t matter which channel events are in; you can have 
everything in a timeline in just one channel if you want. Channels exist solely so that 
you can organize your timeline if you want to.

Once a piece of media is on a timeline, you can adjust where it appears on a time-
line by dragging it back and forth. You can also use the arrow keys: the left and right 
arrow keys move the event backward and forward in time by 1 second, holding down 
shift plus an arrow key will move the event by 10 seconds. You can also select and 
move multiple events on a timeline: click one event to select it, then hold down shift 
and click other events on the timeline to select them as well. Then use the arrow keys 
or drag any of the events to drag them all.

You’ll notice when you move an event on a timeline that the event’s Start and 

A single-page timeline. This timeline 
has two channels; the top one has an 
audio file in it, and the bottom one has 
an image in it.
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End positions in the controls at the top of the timeline window change. If you want 
your event to start or end at a precise moment in time, you can enter values in these 
boxes. Note that changing the end position changes the length of the event. You can 
also change the length of an event by changing the value in the Duration box, or by 
dragging the left or right edge of an event. For audio and video, changing the length 
of an event changes the end point of a clip: if you change the length of an audio clip 
from 0:30 to 0:15, the first 15 seconds of the clip will play regardless of whether you 
dragged the left or right edge of the clip to play it. The maximum length of an audio 
or video event is the length of the audio or video itself: you won’t be able to make the 
duration longer than that.

Using 9.4. multiple-page timelines
The timeline window for a multiple-page timeline is just like the single-page timeline 
window, with the exception that there’s a special channel for pages above the other 
channels in the lower section of the timeline window. Pages can be dragged from the 
pages palette to this channel, where they will appear as events that can be dragged 
back and forth; their duration can be changed.

If a multiple-page timeline is playing, when the playhead reaches the start of a 
page event on the timeline, the book will turn to that page. In addition, when the 
reader manually turns to a page that appears on a multiple-page timeline, the play-
head of the timeline will be moved to the point in time at which that page starts, al-
though the timeline will not play automatically.

Pages that appear in the page channel on a multiple-page timeline do not need to 
appear in their natural sequence: while you could have a timeline that showed pages 
1, 2, 3, 4, and 5 at 0:00, 0:10, 0:20, 0:30, and 0:40, you could also show the pages in 
the order 2, 1, 4, 3, 5. You can even put the same page on the same timeline multiple 
pages (the sequence 1, 2, 3, 2,, 4, 2, for example); when you turn to a page that ap-
pears in the timeline more than once, the timeline will move to the first page event 
that appears on the timeline.

The other channels in a multiple-page timeline work like the channels on a single-
page timeline. Keep in mind that if an event is scheduled to happen when its page is 
not visible, it won’t be seen.

If an object on a multiple-page timeline is on a template that’s used by more than 
one page on the timeline, that object can potentially appear across those pages. For 
example, you could put a movie on the page template used by pages 1 through 5; you 
could then put pages 1 through 5 on a timeline and add the movie to the timeline. As 
the movie plays, the pages will turn.

A multiple-page timeline. This timeline 
has five pages on it and a movie clip 
which appears on every page.
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9.5. Controlling timelines
To use timelines in a Sophie book, you need to make a link that starts them. There 
are a number of ways to trigger this kind of link: you could start a timeline when a 
page is opened, or when the reader clicks something. 

There are four actions in the drop-down menu of link actions that can be used on 
a timeline:

Play•	 . This action starts a timeline playing from whatever point the playhead is cur-
rently at. If the timeline has not been played before, it starts from the beginning.

Play from beginning•	 . This action starts playing a timeline from the beginning.

Rewind•	 . This action moves the playhead of a timeline back to the beginning. It 
doesn’t play the timeline.

Pause•	 . This action pauses the timeline: it stops it playing, but doesn’t move the 
playhead.

Some of these obviously need to be used in conjunction with other links: choosing 
Rewind or Pause won’t actually do anything unless you have a play command some-
where.

When you’ve chosen one of these actions, you need to drag a timeline from the list 
of timelines to the box below the action. When you’ve successfully dragged a timeline 
to the box, the timeline’s name will appear in the box. You can also type in the name 
of the timeline in the box.

The link HUD for a link that plays a 
timeline.
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Working with the 10. network

Using 10.1. remote objects
One of the most basic ways that the network can be used in Sophie is through remote 
objects. Remote objects are objects that live on the network (like a web server) rather 
than on your computer. Remote objects aren’t saved inside of the Sophie book when 
you save it on your computer; they stay on their web server. Using remote objects is a 
good idea if you’re using an enormous movie in your Sophie book, but you want it to 
be small enough so that you can email it to people.

Any sort of media that can be used in Sophie can be used remotely. To use a re-
mote object in your Sophie book, you need to know its URL. Then go to File > Link 
to URI. Enter the URL and then click Okay. The remote object’s icon will appear in 
the media palette that it belongs to. You can use the remote object just like any other 
piece of media in Sophie: just drag it to the page.

When the reader opens a book that includes a remote object, the object will be 
downloaded when the reader gets to the page that the object appears on. If the reader 
doesn’t have a working Internet connection, they won’t see what you intended. If you 
know this is going to be the case, don’t use remote objects in your book.

Using 10.2. Sophie Server
A Sophie Server is a web server that runs the Sophie Server software. If you have 
access to a Sophie Server, you can read and edit books on the Sophie Server; you 
can also add your own books to the Sophie Server so other people can look at them. 
Sophie Server stores versions of books, so you can keep multiple revisions of a book 
that’s in the process of being written.

For information on installing a Sophie Server, see the Sophie developer website at 
http://dev.sophieproject.org.

The servers tab
Most of the Sophie Server functionality is in the servers tab on the right side of the 
Sophie interface. This tab has four palettes.

The servers palette displays a list of all Sophie Servers that you’re currently con-
nected to. To connect to a Sophie Server, use File > Add Server, or click “Add a Server” 
in the books palette of the servers tab.

The server name palette displays the name of the Sophie Server you’re using.

The servers tab when logged 
in to a Sophie Server. 

http://dev.sophieproject.org
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The books palette displays a list of all books on the currently selected Sophie Serv-
er. To use a book on Sophie Server, drag it from this palette to the workspace, which 
will open the most recent revision of the book. If a book in the list has a “+” sign to 
the left of it, there are multiple versions of the book available. Click the “+” sign to 
see a list of the versions, which are arranged by date and time. You can drag out these 
old versions as well.

If the Refresh button is pressed, the server will be queried to see if new books have 
been uploaded by other users.

Other Sophie Server functionality
As noted, you can log into a Sophie Server through the File menu, by selecting File > 
Add Server. Once you’ve done this, there are other commands in this menu that will 
let you access Sophie Server.

If you have a book from the server open and you select File > Save, a new revi-
sion of the book with the same name will be saved to Sophie Server. If, however, you 
choose File > Save As, you’ll be given the option to save the book locally. If you’d like 
a copy of a book that’s on Sophie Server, this is the way to do it.

You can save a book on your computer to Sophie Server by using File > Save As to 
Sophie Server. This will upload the book to the Sophie Server that you’re currently 
connected to. If you’re not currently logged into a Sophie Server, you’ll be prompted 
to log in to one.

Using the 10.3. OKI browser
The Open Knowledge Initiative is a standard for allowing access to databases of me-
dia that can be used educationally. (More information can be found online at http://
www.okiproject.org.) Media in OKI databases can be used in Sophie through the OKI 
tab, which is on the right side of the Sophie interface.

The filter palette lets you input the address of a server (in the Server: field) and a 
term to search for (in the Filter: field). Entering the address of a server and clicking 
Search will connect to an OKI server for the first time; filtering can be used after the 
server is connected.

The assets palette lists resources in the connected server once a server is connect-
ed. Resources can be dragged from this list to the page of the Sophie book you want 
to use them in.

The preview palette shows a preview of a resource when one is selected in the list 
in the assets palette.

The meta palette shows metadata on a resource when one is selected in the list in 
the assets palette.

The OKI tab when logged in 
to an OKI gateway. 

http://www.okiproject.org
http://www.okiproject.org
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Using 10.4. comment frames
Comment frames are another way to use Sophie and the network. Comment frames 
require a Sophie Server to function; however, a Sophie book that uses comment 
frames doesn’t need to be on a Sophie Server to function. When a book has comment 
frames, readers can make comments on a book; these comments are uploaded to the 
Sophie Server and are soon made visible to everyone reading a copy of the book.

To add a comment frame to a book, drag the comment frame out of the compo-
nents palette to a page in your book. A comment frame will appear; in its upper right 
corner there will be a button that says “Write Comment” and on the right side will 
be a scroll bar. You can resize it just like you would a normal frame; you can use the 
content halo to open a content HUD that works exactly like the content HUD on an 
ordinary frame.

When a reader clicks the “Write Comment” button, a window will open which asks 
for an “Author” – a name – and a comment. After these have been entered, the reader 
can click buttons marked “Commit” or “Cancel”. “Commit” enters the comment; it’s 
uploaded to Sophie Server. “Cancel” erases what was just entered and closes the win-
dow.

If the reader has not already logged into a Sophie Server, they’ll be asked to login 
to Sophie Server when opening a book that has comment frames. If they don’t login, 
they won’t see comments.

Comments in a 
comment frame

The Write Comment box
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Working with 11. reader annotations

Using 11.1. stickies
Stickies are little collapsable windows that a reader or author can add to a book. To 
made a new sticky, go to the tools tab; in the stickies palette, click the New Sticky but-
ton. A new sticky will appear on the current page of the current book. You can type as 
much text as you’d like in a sticky; if there’s more text in the sticky than will fit, you 
might need to press the down arrow key to view it.

You can resize the sticky by dragging its lower right corner; you can move it 
around on the page by dragging the title bar. You can delete the sticky by clicking the 
little X in the upper right corner. You can change the color of the sticky by clicking 
the little color box in the title bar; a color picker will appear, allowing you to pick any 
color you like.

You can add as many stickies as you want to a book; they can be added by the read-
er or the author. If there are a lot of stickies in the book, it may be useful to hide them 
sometimes. To do this, uncheck the little box in the middle of the stickies palette.

You can export stickies from a book by going to File > Export Stickies. You’ll be 
prompted for a name to save the stickies as. Once you’ve done this, you can import 
the stickies file, using File > Import Stickies. 

Using the 11.2. highlighter
The highlighter works just like a yellow marker. If you select text, you can press com-
mand-M (on a Mac) or control-M (on a PC) and the text will be highlighted in yellow. 
You can also select text and go to Edit > Highlight Text, which does exactly the same 
thing.

Highlighted text is listed in the markers palette in the order in which the text ap-
pears in the book. If you click on an entry in this palette, you’ll be taken to the page 
on which it appears.

 You can export highlighted text from a book by going to File > Export Highlights. 
You’ll be prompted for a name to save the highlighted text as. Once you’ve done this, 
you can import the highlighted text file, using File > Import Highlights. 

A sticky.

Text highlighted with the highlighter.
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Using the 11.3. notebook
The notebook is a special Sophie book that’s always opened when you start Sophie, 
though its window is not visible. If you go to the books palette, you’ll see a listing for 

“Sophie NoteBook”; if you drag it out to the workspace, you’ll see that it’s a 400 x 400 
Sophie book. The notebook can be manipulated just like any Sophie book; you can 
resize it as you like and add pages to it.

The notebook is a place to keep media that you reuse (page buttons, for example) 
as well as text that you might reuse. You can drag content from other Sophie books to 
the notebook and vice versa. 

A notebook that contains icons for reuse.
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